合规的股票杠杆平台-正规的股票杠杆平台有哪些

通达信爆量竞价打板副图选股指标公式(附源码破译、测评和源码)

发布日期:2024-01-25 06:32    点击次数:86

编程思路破译

X_1赋值:如果模糊匹配品种名称,返回0,否则返回1

X_2赋值:如果模糊匹配品种名称,返回0,否则返回1

X_3赋值:量比>0

X_4赋值:如果属于某板块,返回0,否则返回1

X_5赋值:如果模糊匹配品种名称,返回0,否则返回1

X_6赋值:如果属于某板块,返回0,否则返回1

X_7赋值:100*(开盘价-1日前的收盘价)/1日前的收盘价

X_8赋值:开盘金额/开盘价/自由流通股本(股)*100

X_9赋值:1日前的成交量(手)*10000/自由流通股本(股)

X_10赋值:X_8/X_9*100

X_11赋值:开盘金额/10000>1800

X_12赋值:如果属于某板块,返回0.2,否则返回如果属于某板块,返回0.2,否则返回如果属于某板块,返回0.05,否则返回0.1

X_13赋值:如果X_12=0.2,返回计算涨停价,否则返回如果模糊匹配品种名称ORNAMELIKE(5),返回计算涨停价,否则返回计算涨停价

X_14赋值:X_13=收盘价

X_15赋值:1日前的X_14

X_16赋值:1日前的统计20日中满足X_13=收盘价的天数>=2

X_17赋值:X_11 AND X_1 AND X_2 AND X_3 AND X_4 AND X_5 AND X_6 AND X_15 AND X_7<9.5

输出爆量竞价打板:X_17 AND X_8>0.6 AND X_7>3 AND X_16=0 AND X_10>10

条件选股:通达信爆量竞价打板[日线]成功率测试

测试股票数:5338

共发出信号:0 成功信号:0 失败信号:0 未完成信号:0

信号发出率:0.00% 平均成功率:0.00% 成功率达到50%的股票数有:0.00%

利润1总平均:0.00% 最大平均利润1: 0.00%  最小平均利润1: 0.00%

利润2总平均:0.00% 最大平均利润2: 0.00%  最小平均利润2: 0.00%

程序源码

X_1:=IF(NAMELIKE(7),0,1);

X_2:=IF(NAMELIKE(5),0,1);

X_3:=DYNAINFO(17)>0;

X_4:=IF(INBLOCK(1),0,1);

X_5:=IF(NAMELIKE(8),0,1);

X_6:=IF(INBLOCK(9),0,1);

X_7:=100*(OPEN-REF(CLOSE,1))/REF(CLOSE,1);

X_8:=DYNAINFO(15)/OPEN/FINANCE(46)*100;

X_9:=REF(VOL*10000/FINANCE(46),1);

X_10:=X_8/X_9*100;

X_11:=DYNAINFO(15)/10000>1800;

X_12:=IF(INBLOCK(1),0.2,IF(INBLOCK(9),0.2,IF(INBLOCK(2),0.05,0.1)));

X_13:=IF(X_12=0.2,ZTPRICE(REF(CLOSE,1),0.2),IF(NAMELIKE(7) OR NAMELIKE(5),ZTPRICE(REF(CLOSE,1),0.05),ZTPRICE(REF(CLOSE,1),0.1)));

X_14:=X_13=CLOSE;

X_15:=REF(X_14,1);

X_16:=REF(COUNT(X_13=CLOSE,20)>=2,1);

X_17:=X_11 AND X_1 AND X_2 AND X_3 AND X_4 AND X_5 AND X_6 AND X_15 AND X_7<9.5;

爆量竞价打板:X_17 AND X_8>0.6 AND X_7>3 AND X_16=0 AND X_10>10;

该公式包含未来函数:DYNAINFO该公式包含未来函数:FINANCE

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。